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INTRODUCTION

 This is for the TOC, leave it here
Part of this text frame MUST
be on the page for this to work!

Reshaping Dimensions

This chapter focuses on the Illustrator tools and func-
tions that allow you to create objects that appear to move 
beyond two-dimensional space. With warps and enve-
lopes you can easily use familiar vector tools to bend, and 
bow objects (and text) in two dimensional space, and 
with envelope meshes you can begin to create an illusion 
of depth as well. Using Illustrator’s 3D effects you actu-
ally do revolve, extrude, rotate, and map objects in three 
dimensions. And then, the Perspective Grid tool helps you 
to create art based on linear perspective drawing; using 
one, two or three vanishing points. All of these demand a 
bit of a different headset, than flat Illustrator objects, and 
the manipulating of the mesh. 3D and perspective grid in 
their live states work quite differently from other Illustra-
tor objects. If you decide to expand the art, they become 
merely complex vector objects, letting you work upon 
them using any of Illustrator’s editing tools.

WARPS AND ENVELOPING 
Warps and envelopes may look similar at first, but there’s 
an important difference between them. Warps are applied 
as live effects—meaning they can be applied to objects, 
groups, or layers. Warps strengths are they are easy to cre-
ate by choosing from the predefined options in the Warp 
dialogs; and that you can save them within a graphic style, 
to apply to other objects. Envelopes, on the other hand, 
are also live, but rather than effects, they’re actual objects 
that contain artwork. Envelopes strengths are that you can 
edit or customize the envelope shape, and Illustrator will 
conform the contents of the envelope to the contour.

Warps 
Applying a warp is actually quite simple. Target an object, 
group, or layer and choose Effect > Warp > Arc. (It doesn’t 
matter which warp effect you choose, because you’ll be 
presented with the Warp Options dialog, where you can 

Smart people use Smart Guides

When you work with warps or 

envelopes, it may become dif‑

ficult to edit artwork that has an 

appearance applied to it. With 

Smart Guides turned on, Illustrator 

highlights the art, making it easier 

to identify the actual artwork (and 

not the appearance). Use C‑U/Ctrl-

U to turn Smart Guides on and off. 

—Mordy Golding

Live effects from fx

Access any live effects from the Ef‑

fects menu, and from the fx icon 

in the bottom of the Appearance 

panel. To simplify instructions in 

this chapter, we’ll be using the 

convention Effect>3D or Effect> 

Warp. To edit an effect, select the 

effect in the Appearance panel 

and click the underlined effect 

name, or double-click the fx icon 

to the right of the effect name.

The three Envelope buttons in the Control panel, 
from left to right: Edit Envelope, Edit Contents, 
and Envelope Options

Deleting a mesh point

To delete a mesh point from a 

warp or mesh envelope, choose 

the Mesh tool and Option-click/

Alt-click the point you’d like to de‑

lete. —Jean-Claude Tremblay
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choose from any of the 15 different warps.) While the 
warp effects are “canned” in the sense that you can’t make 
adjustments to the effects directly, you can control how a 
warp appears by changing the Bend value, as well as the 
Horizontal and Vertical Distortion values.

Once you’ve applied a warp, you can edit it by open-
ing the Appearance panel and clicking on the warp effect. 
Like all effects, a warp can be applied to just the fill, or just 
the stroke—and if you edit the artwork, the warp updates 
as well. Since warps are effects, you can include them in a 
graphic style, which can then be applied to other artwork.

Envelopes 
While warp effects do a nice job of distorting artwork 
(and allow you to save the effect as a graphic style), Illus-
trator envelopes provide a higher level of control. 

There are three ways to apply envelopes. The simplest 
way is to create a path you want to use as your envelope. 
Make sure it’s at the top of the stacking order—above 
the art you want to place inside the envelope. Then, with 
the artwork and your created path both selected, choose 
Object > Envelope Distort > Make with Top Object. Illus-
trator will create a special kind of object: an envelope. This 
object you created becomes an envelope container, which 
appears in the Layers panel as <Envelope>. You can edit 
the path of the envelope with any transformation or edit-
ing tools; the artwork inside will update to conform to the 
shape. To edit the contents of the envelope, click the Edit 
Contents button in the Control panel or choose Object > 

Envelope Distort > Edit Contents. If you then look at the 
Layers panel, you’ll notice that the <Envelope> now has 
a disclosure triangle that reveals the contents of the enve-
lope—the artwork you placed. You can edit the artwork 
directly or even drag other paths into the <Envelope> in 
the Layers panel. To again edit the envelope itself, choose 
Object > Envelope Distort > Edit Envelope.

There are two other types of envelopes, and they’re 
closely related. Both types use meshes to provide even 
more distortion control. When using the first type, the 

Envelope distort options

To use envelopes to distort art‑

work containing pattern fills or 

linear gradients, choose Object > 

Envelope Distort > Envelope Op‑

tions and enable the appropriate 

options. —Mordy Golding

Isolation mode for envelopes

An easy way to edit an envelope: 

double-click it to enter isolation 

mode. —Jean-Claude Tremblay

The tools that appear in the Control panel when 
an envelope warp is selected; you can change the 
shape of the warp using the pop-up menu

The controls that appear in the Control panel 
when an envelope mesh is selected; you can 
easily change the number of rows and columns, 
and restore the object to its original shape using 
the Reset Envelope Shape button

The building above by Michael Cressy was turned 
into the building on the right using the drawing 
tools and then modified with envelopes for each 
of the windows, the building, and the stacks 
using; Object>Envelope Distort>Make with Mesh.
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3D

envelope warp, you choose the overall envelope form from 
a pop-up list of options. When you use the envelope mesh, 
instead of starting from presets, you begin by choosing 
how many rows and columns your mesh will contain. 

To create an envelope warp, select an object and 
choose Make with Warp (Object > Envelope Distort). This 
will open the Warp dialog. Once you choose a warp and 
click OK, Illustrator converts that warp to an envelope 
mesh. The Control panel will display the Envelope Warp 
controls, including a pop-up menu that lets you choose 
a different shape for the warp if you want to. You can 
edit the envelope warp’s individual mesh points with the 
Direct Selection tool to distort not only the outer edges of 
the envelope shape, but also the way art is distorted within 
the envelope itself. To provide even more control, use the 
Mesh tool to add more mesh points as desired.

To create an envelope mesh, select your artwork and 
choose Object > Envelope Distort > Make with Mesh. 
After you’ve chosen how many mesh points you want, 
Illustrator will create the envelope mesh. The Envelope 
Mesh tools in the Control panel will appear, allowing you 
to easily change the number of rows and columns, and 
restore the envelope mesh to its original shape if neces-
sary. You can also use the Direct Selection tool to edit the 
points and use the Mesh tool to add mesh points. (But 
if you use other tools, you’ll need to switch back to the 
Selection tool if you want the Envelope Mesh controls to 
reappear in the Control panel.)

3D EFFECTS 
Illustrator offers you the power to transform any two-
dimensional (2D) shape, including type, into a shape 
that looks three-dimensional (3D). As you’re working in 
Illustrator’s 3D effect dialogs, you can change your 3D 
shape’s perspective, rotate it, and add lighting and surface 
attributes. And because you’re working with a live effect, 
you can edit the source object at any time and observe the 
resultant change in the 3D shape immediately. You can 
also rotate a 2D shape in 3D space and change its perspec-

2D or not 2D…? 

Illustrator’s 3D objects are only 

truly three-dimensional while 

you’re working with them in a 3D 

effect dialog. As soon as you’re 

done tweaking your object and 

you click OK to close the dialog, 

the object’s three-dimensional 

qualities are “frozen”—almost as 

if Illustrator had taken a snapshot 

of the object—until the next time 

you edit it in a 3D dialog. On the 

page, it’s technically a 2D render‑

ing of a 3D object that can only be 

worked with in two-dimensional 

ways. But because the effect is 

live, you can work with the object 

in 3D again any time you want, 

by selecting the object and then 

double-clicking the 3D effect listed 

in the Appearance panel.

Extruding an object using the Effect > 3D > 
Extrude & Bevel dialog—the two-dimensional ob-
ject on the left was extruded to create the three-
dimensional version

Hiding the 3D…

To speed up your screen redraw, 

you can temporarily hide a 3D 

effect without losing the settings. 

To do so, click on the Eye for that 

3D effect in the Appearance panel 

(click again to make it visible).
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tive. Finally, Illustrator lets you map artwork previously 
saved as a symbol onto any of your 3D object’s surfaces. 
Remember that Illustrator is primarily a 2D program—its 
3D capabilities are very limited when compared to the 
plethora of available 3D programs.

To begin, think of Illustrator’s horizontal ruler as the 
X axis and the vertical ruler as the Y axis. Now imagine 
a third dimension that extends back into space, perpen-
dicular to the flat surface of your monitor. This is the 
Z axis. There are two ways to create a 3D shape using 3D 
effects. The first method is by extruding a 2D object back 
into space along the Z axis, and the second is by revolving 
a 2D object around its Y axis, up to 360°.

To apply a 3D effect to a selected object, choose one 
of the 3D effects from the fx icon in the Appearance 
panel (or via the Effect menu). To simplify the instruc-
tions throughout this chapter, we’ll be using the conven-
tion choose Effect > 3D. Once you apply a 3D effect to 
an object, it will show up in the Appearance panel. As 
with other appearance attributes, you can edit the effect, 
change the position of the effect in the panel’s stacking 
order, and duplicate or delete the effect. You can also save 
3D effects as reusable graphic styles so that you can apply 
the same effect to a batch of objects. Once the style has 
been applied, you can modify any of the style parameters 
by clicking the underlined effect name in the Appearance 
panel, or double-clicking the fx icon to the right of the 
effect name. Editing the 2D path will then update the 3D 
rendering. Following are a few of the key parameters for 
working in the different kinds of 3D:

•	 To extrude a 2D object, begin by creating a path; the 
path can be open or closed path, and can contain a stroke, 
a fill, or both (if your shape contains a fill, it’s best to begin 
with a solid color, not gradient or pattern). With your 
path selected, choose Extrude & Bevel from the Effect > 
3D submenu. In the lower portion of the dialog, enter a 
point size for depth for your object in the Extrude Depth 
field, or drag the slider. Adding a cap to your object make 

3D—Three dialogs

There are three different 3D ef‑

fects, and some features overlap. 

If all you need to do is change 

the perspective of an object, use 

Rotate. If you want to map a sym‑

bol to the object, use either Re‑

volve or Extrude & Bevel (you can 

still rotate an object from these as 

well). —Brenda Sutherland

Customized bevels!

All the 3D Bevel shapes are lo‑

cated inside the file “Bevels.ai” 

(for Mac: Adobe Illustrator CS5 > 

Required > Resources > en_US > 
Bevels.ai, and for Win: Adobe 

Illustrator CS4 > Support Files > Re‑

quired > Resources > en_US > Bev‑

els.ai). Each bevel path is saved as 

a Symbol inside this document. To 

add a custom bevel, draw a new 

path, drag it to the Symbols panel, 

name it, and resave the file. —
Jean-Claude Tremblay

Solid advice on 3D colors

You’ll get best results using solid 

fill colors for 3D objects. Gradients 

and pattern fills don’t produce re‑

liable results.

Not enough steps…

Click the More Options button to 

adjust Blend steps; find a setting 

between the default (25) and the 

maximum (256) that’s smooth 

enough, but not too slow to draw 

(and print).
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the ends appear solid, disabling the cap option makes 
your object appear hollow (see first two figures at left).

You can choose from ten different bevels to style the 
edges of your object; bevels can be added to the original 
using Bevel Extent Out, or carved out of the original using 
Bevel Extent In (second pair of figures at left). 

•	 To revolve an object around it’s Y (vertical) axis, 
begin by creating a path. The path can be open or closed, 
stroked, filled, or both. With your path selected, choose 
Effect > 3D > Revolve to open 3D Revolve Options. Drag 
the slider to set the number of degrees or enter a value 
from 1 to 360 in the Angle text field. An object that is 
revolved 360° will appear solid. An object revolved less 
than 360° will appear to have a wedge carved out of it. If 
you offset the rotation from the object’s edge, a 3D shape 
will appear to be carved out in the center. 

•	 To Rotate 2D or 3D objects in 3D space, choose 
Effects > 3D > Rotate. The 3D Rotate Options dialog con-
tains a cube representing the planes that your shape can 
be rotated through. Choose a preset angle of rotation from 
the Position menu, or enter values between –180 and 180 
into the X, Y, and Z text fields. To manually rotate your 
object around one of its three axes, simply click on the 
edge of one of the faces of the white cube and drag. The 
edges of each plane are highlighted in a corresponding 
color that tells you through which of the object’s three 
planes you’re rotating it. The object’s rotation is con-
strained within the plane of that particular axis. If you 
wish to rotate your object relative to all three axes at once, 
click directly on a surface of the cube and drag, or click 
in the black area behind the cube and drag. Values in all 
three text fields will change. And if you simply want to 
rotate your object, click and drag inside the circle, but out-
side the cube itself.

•	 To change the perspective of an object, enter a num-
ber between 0 and 160 in the Perspective field, or drag 
the slider pop-up. A smaller value simulates the look of 
a telephoto camera lens, while a larger value simulates a 
wide-angle camera lens.

For the smoothest 3D

When creating profile objects for 

3D, draw as few anchor points 

as possible. Each anchor point 

produces an additional surface 

to render, and might also create 

potential problems if you’re later 

mapping artwork onto surfaces.  

—Jean-Claude Tremblay

Bevel error messages…

If you apply bevels to some ob‑

jects (like stars), you might see the 

error, “Bevel self-intersection may 

have occurred” when you click 

“Preview”—this may or may not 

actually mean there’s a problem.

An example of rotating an object in 3D space

Left to right: Turn cap on for solid, Turn cap off 
for hollow, Bevel Extent In, Bevel Extent Out

Revolving an object using the Effect > 3D > Re-
volve dialog—the open path on the left was re-
volved to create the 3D chess pawn on the right
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Applying surface shading to 3D objects 
Illustrator allows you to choose different shading (rang-
ing from dull and unshaded matte surfaces to glossy and 
highlighted surfaces that look like plastic), as well as cus-
tomized lighting conditions. The Surface shading option 
appears as part of both the 3D Extrude & Bevel and the 
3D Revolve Options dialogs. Choosing Wireframe as 
your shading option will result in a transparent object, 
the contours of which are overlaid with a set of outlines 
describing the object’s geometry. Choosing No Shading, 
results in a flat-looking shape with no discernible surfaces. 
Choosing the Diffused Shading option results in your 
object having a soft light cast on its surfaces, while choos-
ing the Plastic Shading option will make your object look 
as if it’s molded out of shiny, reflective plastic. For mapped 
surfaces, enable “Shade Artwork” in the Map Art dialog.

If you choose either the Diffused Shading or Plastic 
Shading option, you can further refine the look of your 
object by adjusting the direction and intensity of the light 
source illuminating your object. By clicking the More 
Options button, the dialog will enlarge and you’ll be able 
to make changes to the Light Intensity, Ambient Light 
level, Highlight Intensity, Highlight Size, and number of 
Blend Steps. You can also choose a custom Shading Color 
to add a color cast to the shaded surfaces. If you choose 
to maintain a spot color assigned to your Extruded object 
during output, by enabling the Preserve Spot Colors 
checkbox, be aware that this removes custom shading and 
resets your Shading Color to Black. If you choose Preserve 
Spot Colors, you should enable Overprint Preview (View 
menu) so you can see your shading and color accurately.

The More Options dialog expanded includes the light 
source sphere (shown at right). The small white dot within 
this sphere indicates the position of the light source, while 
the black box around it highlights this light source as cur-
rently selected. There is always one light source by default. 
Click and drag this dot within the sphere to reposition 
your light. You’ll see the lighting automatically updated on 
your 3D object if the Preview option is enabled. 

3D effect—pass it on

Although in this book we gener‑

ally recommend working with the 

New Art Has Basic Appearance 

setting disabled, you might want 

enable it when working with 3D 

effects. Otherwise, any new paths 

that you create subsequent to 

applying 3D effects to an object 

will also have the same appear‑

ance set, unless you first clear the 

appearance set from the panel, or 

click on the default fill and stroke 

icon in the tools panel. On the 

other hand, if you want your next 

object to have the same 3D effects 

as the one you just created, leave 

New Art Has Basic Appearance 

disabled.

Rotate objects in three dimensions by using the 
Effect > 3D > Rotate dialog (or the upper halves 
of the Revolve and the Extrude & Bevel dialogs); 
the symbol on the left, rotated in 3D space to cre-
ate the figure on the right (any 2D object can be 
rotated in 3D space, without making the object 
itself 3D)

The expanded More Options dialog shows the 
position of your light source within the sphere; 
the three icons located below this sphere from 
left to right are: “Move selected light to back of 
object,” “New Light,” and “Delete Light”
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Clicking on the “New Light” icon (below the sphere) 
adds more light sources. This also selects the new light 
source (indicated by the black “highlight” box around 
it). Adjust each selected source independently using the 
lighting controls (to the right of the sphere). The first 
icon below the sphere, the “Move selected light to back of 
object” feature, creates back lighting for an object. When 
your light source is behind an object, the source indicator 
inverts to a black dot within a white square. When using 
multiple light sources, this difference helps you see which 
light sources are behind or in front of an object. Select a 
light source and click this icon to toggle the light to the 
front or back of your object, depending on its current 
position. To delete a light source, first select it, then click 
the Trash icon beneath the sphere (you can delete all but 
one default light source).

Mapping art onto an object 
To map artwork onto an object (as with the design on the 
ring to the left) first define the art that you wish to map 
onto a surface as a symbol; select the artwork you want to 
map, and drag it to the Symbols panel. You may also want 
to define a number of symbols. For instance, the design on 
the ring above right is from one symbol. To add engraving 
inside the ring, you’d create a second symbol and add it in 
the Map Art dialog.

Map the symbols onto your 3D objects from the 
Extrude & Bevel or Revolve Options dialogs. In either of 
these 3D options boxes, you simply click on the Map Art 
button, then choose one of the available symbols from 
the menu. You can specify which of your object’s surfaces 
the artwork will map onto by clicking on the left and 
right Arrow keys. The selected surface will appear in the 
window; then you can either scale the art by dragging the 
handles on the bounding box, or make the art expand to 
cover the entire surface by clicking the Scale to Fit button. 
Note that as you click through the different surfaces, the 
selected surface will be highlighted with a red outline in 
your document window. Your currently visible surfaces 

Mapping—don’t get lost!

Here are some tips to help you 

avoid confusion about the surface 

to which you’re mapping symbols:

•	Remember to choose a surface. 

Select by clicking the Arrow keys 

to view each surface.

•	 To identify the surface you want 

to map, look for the red high‑

light on the object itself, rather 

than looking at the flattened 

proxy in the Map Art dialog.

•	A stroke will add more surfaces 

to an object than a fill because 

a stroke creates a hollow inside 

the object, which is also treated 

as a surface.

•	A stroke can obscure mapped 

art on a side or inside of a sur‑

face that can’t be seen. 

—Brenda Sutherland

The above design was mapped onto the ring 
below it using the Map Art feature (result shown 
above right). The ring was created using the 3D 
Revolve effect with an “offset” value added.

Mapping with gradients

Gradients can be saved as sym‑

bols, but they are rasterized when 

mapped. The rasterized resolution 

of the resulting image is deter‑

mined from the resolution setting 

in the “Document Raster Effects 

Settings.” You can adjust this 

resolution by going to Effects > 

Document Raster Effects Settings.
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will appear in light gray in the Map Art dialog, and sur-
faces that are currently hidden will appear dark.
Note: To see artwork mapped onto the side surfaces of your 
object, make sure the object has a stroke of None. 

THE PERSPECTIVE GRID 
The perspective grid allows you to create art on a ground 
plane representing real world space as viewed by the 
human eye. Distances between edges converge as you 
approach the horizon, the terminal point of our vision. 
This tool is useful for creating scenes such as cityscapes 
where buildings or roads narrow in view as they recede 
from our vision eventually vanishing on the horizon.

With this Perspective Grid toolset you can draw 
dynamically within the perspective environment itself so 
that shapes or objects automatically conform to the per-
spective grid as they are created, or you can attach existing 
flat vector art to the perspective grid and select it using 
the Perspective Selection tool to transform the art to the 
perspective environment. You can even position the grid 
on top of a reference photograph to add vector content. 
Symbols, text and objects created with the 3D effect are 
also supported within the perspective environment.

To begin working in perspective mode first define 
your perspective environment. Click on the Perspective 
Grid tool found in the toolbar to display the perspec-
tive grid on your Artboard or click View>Perspective 
Grid>Show Grid. The default is Two Point Perspec-
tive consisting of two vanishing points. For one point 
perspective choose View> Perspective Grid>One Point 
Perspective>1P Normal View which has a single vanishing 
point or Three Point Perspective>3P Normal View which 
has three vanishing points (if a perspective grid is custom-
ized and saved, it will appear in the respective submenu 
for 1P, 2P or 3P Normal View as an additional choice). 

When the Perspective Grid tool is selected your grid 
is displayed with grid plane control points on its extremi-
ties (but some disappear when the Perspective Selection 
tool is used). These controls allow you to manually adjust 

To map or wrap...?

Although maps can be used in a 

variety of ways to add designs or 

texture effects to an object, such 

as a label on a bottle, they can 

also be used to cover an entire ob‑

ject (see pawn above mapped with 

a wood grain image). However, 

complex objects produce a greater 

number of surfaces, which can 

make the rendering process very 

slow and perhaps generate errors. 

Enable “Shade Artwork” in the 

Map Art dialog if you intend to 

use lighting and shading options 

on a mapped surface.

More on mapping 

Even an object’s red highlight can 

fool you. If the symbol isn’t map‑

ping to a selected surface, it may 

be because it’s being mapped to 

the inside of the surface..

Need to get rid of the grid?

Once the Perspective Grid tool 

is used, the grid appears and re‑

mains regardless of what tool is 

used. Hide the grid by toggling 

it off using Command-Shift-I/

Ctrl-Shift-I (View>Perspective 

Grid>Hide Grid). The visible grid 

is not visible on finished art when 

printed or exported.
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parameters such as grid height, width, vanishing points, 
angles and repositioning of planes etc. Scrolling the cursor 
over these controls yields an indicator below the pointer 
showing the directional choices available for that control.

To save a customized grid choose View>Perspective 
Grid>Save Grid As Preset. The new grid is saved under 
the respective perspective type, for example a customized 
one point perspective grid will be saved as an option to 1P 
Normal View when View>Perspective Grid>Two Point 
Perspective fly out menu is displayed. The Define Grid 
dialog box (View>Perspective Grid>Define Grid) allows 
you to adjust the grid with greater numerical precision 
and save as a preset for further uses.

To begin working within your defined environ-
ment first select an active plane to work in. The cube in 
the upper left hand corner of the work area is the Plane 
Switching Widget. Use the Perspective Grid tool (or any 
drawing or editing tool) to click on a cube side, the active 
plane is highlighted with a color, Orange for example is 
the default color for the right plane (see figures at left). 
The active plane means that anything drawn in perspec-
tive will conform to the perspective of that specific plane 
regardless of where it is drawn on the Artboard (only one 
plane can be active at any time). The Perspective Grid tool 
cursor also indicates this with the shaded side of a cube 
below its pointer.

 Once an active plane is selected you can use any 
drawing or editing tool to draw in perspective mode. 
Simply select a tool such as the Rectangle tool, and begin 
drawing on the grid. Use the Perspective Selection tool 
(hidden under the Perspective Grid tool in the toolbar) 
to select and move art within an active plane (the cursor 
also has a line and an arrow, indicating the active plane). 
When you move objects within your plane using this tool, 
your objects appear to recede and advance within the 
perspective grid (using the normal Selection tool freezes 
an object’s shape to the current viewpoint, so it won’t con-
tinue to transform as you move it). You can also use the 
Perspective Selection tool to select existing vector objects 

The Plane Switching Widget shown left with the 
left side highlighted in blue indicates that the left 
plane (grid) is active. click on a side of the cube 
with one of the perspective tools (or press 1, 2 or 
3 on your keyboard) to activate a different plane 
(second and third widget): click the area outside 
the cube within the widget (or press 4) to deacti-
vate perspective mode which allows you to draw 
normally (widget at far right).

Grid control points can be manually adjusted on 
the grid itself or more precisely using the Define 
Perspective Grid dialog box (View>Perspective 
Grid>Define Grid). Presets can then be saved for 
reuse. View>Perspective Grid>Show Rulers dis-
plays a ruler on the visible grid.

The above image shows a square drawn with the 
Rectangle tool. Notice the Plane Switching Wid-
get indicates that the right plane is active hence 
the illustrated shape in perspective relative to the 
right vanishing point (the cursor also includes a 
line and an arrow which also indicates the active 
plane). The same square copied and moved with 
the Perspective Selection tool dynamically trans-
forms it as it moves within the perspective plane.

The Perspective Grid tool (left) opens the per-
spective grid with grid plane controls visible; 
the Perspective Selection tool (right) is used for 
bringing objects, text or symbols into perspec-
tive, moving these items in perspective space or 
switching active planes.
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and attach them to the perspective grid. To do so simply 
activate a plane then select and drag the object to the per-
spective grid. When you use the Perspective Grid tool to 
select an object that’s already associated with the grid, the 
associated side of the cube automatically becomes high-
lighted.

Clicking in the area outside the cube within the widget 
(or pressing 4) deactivates all perspective planes so you 
can draw in normal mode (no perspective applied) see fig-
ure to right. Once your object is created, use the Perspec-
tive Selection tool (or press 1,2 or 3) to activate a plane by 
clicking on a Widget side and drag the object to position it 
in perspective. To move more than one object in perspec-
tive drag a marquee over the objects with the Perspective 
Selection tool and then move to reposition (this collects 
only the objects on the active plane). 

If you wish to move an object perpendicular to its cur-
rent location, hold down the 5 key (top row of numbers 
on keyboard only, not 5 on right numeric keys) as you 
drag with the Perspective Selection tool or to duplicate an 
object and move it perpendicular to the original’s posi-
tion, hold Option-5/Alt-5 as you drag. 

With the Perspective Grid tool, double click on any of 
the grid plane controls (the three circles below where the 
planes intersect) to open a Vanishing Plane or Floor Plane 
dialog which allows you to move a plane precisely, with or 
without selecting the objects associated with that plane.

To work on an object in normal mode after applying 
perspective; use the Object>Perspective>Release with 
Perspective or use contextual menu and choose from 
the Perspective menu (this function does not return 
an object to a normal state if created initially without 
perspective but just detaches it from the perspective 
plane). The object can now be modified normally, how-
ever, in order to reattach it to the plane you must use 
Object>Perspective>Attach to Active Plane; once an 
object has been detached from a plane. If the object is not 
reattached this way, using the Perspective Selection tool 
will automatically add a new perspective to the object.

Draw normally first...

Create Text and symbols normally 

first and then use the Perspective 

Selection tool to attach it to an 

active plane. Once in perspective, 

use Object>Perspective>Edit Text 

to modify.

Perspective is permanent!

Once perspective is applied to an 

object it cannot be released to re‑

turn to its original (normal) state 

as with other effects, so save a 

copy of the original if necessary.

In this example, clicking within the Plane Switch-
ing Widget but outside the cube, deactivated the 
perspective grid (note the cyan colored area sur-
rounding the cube), so the rectangke was drawn 
in normal mode; to later apply perspective to the 
rectangle, select the Grid Selection tool, click on 
a Widget side to activate a plane. and drag the 
rectangle to the desired location.

Perspective Limits

•	An Artboard can contain only 

one perspective grid. However, 

you can position a grid across 

more than one Artboard. 

•	 Symbols consisting of effects 

such as rasters, legacy text, non 

native art, envelope objects and 

gradient mesh art cannot be ap‑

plied to the perspective grid. 

•	You cannot apply perspective 

mode to the Flare tool.


